182 строки
6.6 KiB
Plaintext
182 строки
6.6 KiB
Plaintext
Name: perl-Scope-Guard
|
|
Summary: Lexically scoped resource management
|
|
Version: 0.21
|
|
Release: 14%{?dist}
|
|
License: GPL+ or Artistic
|
|
Source0: https://cpan.metacpan.org/authors/id/C/CH/CHOCOLATE/Scope-Guard-%{version}.tar.gz
|
|
Vendor: Microsoft Corporation
|
|
Distribution: Azure Linux
|
|
URL: https://metacpan.org/release/Scope-Guard
|
|
BuildArch: noarch
|
|
# Module Build
|
|
BuildRequires: coreutils
|
|
BuildRequires: findutils
|
|
BuildRequires: make
|
|
BuildRequires: perl-interpreter
|
|
BuildRequires: perl-generators
|
|
BuildRequires: perl(ExtUtils::MakeMaker)
|
|
# Module Runtime
|
|
BuildRequires: perl(Carp)
|
|
BuildRequires: perl(Exporter)
|
|
BuildRequires: perl(strict)
|
|
BuildRequires: perl(warnings)
|
|
# Test Suite
|
|
BuildRequires: perl(Test::More)
|
|
# Runtime
|
|
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
|
|
|
|
%{?perl_default_filter}
|
|
|
|
%description
|
|
This module provides a convenient way to perform cleanup or other forms of
|
|
resource management at the end of a scope. It is particularly useful when
|
|
dealing with exceptions: the Scope::Guard constructor takes a reference to
|
|
a subroutine that is guaranteed to be called even if the thread of
|
|
execution is aborted prematurely. This effectively allows lexically-scoped
|
|
"promises" to be made that are automatically honored by perl's garbage
|
|
collector.
|
|
|
|
%prep
|
|
%setup -q -n Scope-Guard-%{version}
|
|
|
|
%build
|
|
perl Makefile.PL INSTALLDIRS=vendor
|
|
make %{?_smp_mflags}
|
|
|
|
%install
|
|
make pure_install DESTDIR=%{buildroot}
|
|
find %{buildroot} -type f -name .packlist -exec rm -f {} \;
|
|
%{_fixperms} %{buildroot}
|
|
|
|
%check
|
|
make test
|
|
|
|
%files
|
|
%doc Changes README t/
|
|
%{perl_vendorlib}/Scope/
|
|
%{_mandir}/man3/Scope::Guard.3*
|
|
|
|
%changelog
|
|
* Fri Oct 15 2021 Pawel Winogrodzki <pawelwi@microsoft.com> - 0.21-14
|
|
- Initial CBL-Mariner import from Fedora 32 (license: MIT).
|
|
|
|
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.21-13
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
|
|
|
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.21-12
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
|
|
|
* Thu May 30 2019 Jitka Plesnikova <jplesnik@redhat.com> - 0.21-11
|
|
- Perl 5.30 rebuild
|
|
|
|
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.21-10
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
|
|
|
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.21-9
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
|
|
|
* Wed Jun 27 2018 Jitka Plesnikova <jplesnik@redhat.com> - 0.21-8
|
|
- Perl 5.28 rebuild
|
|
|
|
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.21-7
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
|
|
|
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.21-6
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
|
|
|
* Sun Jun 04 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.21-5
|
|
- Perl 5.26 rebuild
|
|
|
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.21-4
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
|
|
|
* Sun May 15 2016 Jitka Plesnikova <jplesnik@redhat.com> - 0.21-3
|
|
- Perl 5.24 rebuild
|
|
|
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.21-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
|
|
|
* Mon Jul 20 2015 Paul Howarth <paul@city-fan.org> - 0.21-1
|
|
- Update to 0.21
|
|
- Remove useless use of UNIVERSAL::isa (CPAN RT#105948)
|
|
- Classify buildreqs by usage
|
|
- Drop obsoletes/provides for old tests sub-package
|
|
- Drop %%defattr, redundant since rpm 4.4
|
|
- Don't need to remove empty directories from the buildroot
|
|
- Don't use macros for common commands
|
|
- Make %%files list more explicit
|
|
|
|
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.20-15
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
|
|
|
* Fri Jun 05 2015 Jitka Plesnikova <jplesnik@redhat.com> - 0.20-14
|
|
- Perl 5.22 rebuild
|
|
|
|
* Wed Aug 27 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.20-13
|
|
- Perl 5.20 rebuild
|
|
|
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.20-12
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
|
|
|
* Fri Jan 31 2014 Paul Howarth <paul@city-fan.org> - 0.20-11
|
|
- Drop tests subpackage; move tests to main package documentation
|
|
|
|
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.20-10
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
|
|
|
* Sat Jul 20 2013 Petr Pisar <ppisar@redhat.com> - 0.20-9
|
|
- Perl 5.18 rebuild
|
|
|
|
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.20-8
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
|
|
|
* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.20-7
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
|
|
|
* Mon Jun 11 2012 Petr Pisar <ppisar@redhat.com> - 0.20-6
|
|
- Perl 5.16 rebuild
|
|
|
|
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.20-5
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
|
|
|
* Mon Jun 20 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.20-4
|
|
- Perl mass rebuild
|
|
|
|
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.20-3
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
|
|
|
* Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.20-2
|
|
- 661697 rebuild for fixing problems with vendorach/lib
|
|
|
|
* Fri Dec 17 2010 Iain Arnell <iarnell@gmail.com> 0.20-1
|
|
- update to latest upstream version
|
|
- clean up spec for modern rpmbuild
|
|
- US spelling in description
|
|
|
|
* Thu May 06 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.12-2
|
|
- Mass rebuild with perl-5.12.0
|
|
|
|
* Fri Apr 16 2010 Chris Weyl <cweyl@alumni.drew.edu> 0.12-1
|
|
- update by Fedora::App::MaintainerTools 0.006
|
|
- PERL_INSTALL_ROOT => DESTDIR
|
|
- updating to latest GA CPAN version (0.12)
|
|
- dropped old BR on perl(Test::Pod::Coverage)
|
|
|
|
* Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 0.03-6
|
|
- rebuild against perl 5.10.1
|
|
|
|
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.03-5
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
|
|
|
* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.03-4
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
|
|
|
* Thu Mar 06 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.03-3
|
|
Rebuild for new perl
|
|
|
|
* Mon Nov 26 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.03-2
|
|
- bump
|
|
|
|
* Tue Sep 18 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.03-1
|
|
- Specfile autogenerated by cpanspec 1.71.
|