14 строки
491 B
Diff
14 строки
491 B
Diff
diff --git a/llvm/lib/CodeGen/AsmPrinter/CMakeLists.txt b/llvm/lib/CodeGen/AsmPrinter/CMakeLists.txt
|
|
index eb924282a..c77c140b9 100644
|
|
--- a/llvm/lib/CodeGen/AsmPrinter/CMakeLists.txt
|
|
+++ b/llvm/lib/CodeGen/AsmPrinter/CMakeLists.txt
|
|
@@ -44,3 +44,8 @@ add_llvm_component_library(LLVMAsmPrinter
|
|
Support
|
|
Target
|
|
)
|
|
+
|
|
+if (CMAKE_COMPILER_IS_GNUCXX)
|
|
+ set_source_files_properties(DwarfCompileUnit.cpp PROPERTIES
|
|
+ COMPILE_FLAGS -fno-strict-aliasing)
|
|
+endif()
|