488 строки
17 KiB
Diff
488 строки
17 KiB
Diff
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
|
|
index fad04716..7adba3a3 100644
|
|
--- a/Utilities/cmnghttp2/CMakeLists.txt
|
|
+++ b/Utilities/cmnghttp2/CMakeLists.txt
|
|
@@ -33,10 +33,12 @@ set(NGHTTP2_SOURCES
|
|
lib/nghttp2_pq.c
|
|
lib/nghttp2_priority_spec.c
|
|
lib/nghttp2_queue.c
|
|
+ lib/nghttp2_ratelim.c
|
|
lib/nghttp2_rcbuf.c
|
|
lib/nghttp2_session.c
|
|
lib/nghttp2_stream.c
|
|
lib/nghttp2_submit.c
|
|
+ lib/nghttp2_time.c
|
|
lib/nghttp2_version.c
|
|
)
|
|
|
|
diff --git a/cmakeconfig.h.in b/cmakeconfig.h.in
|
|
index 8e7583e0..d93fed6a 100644
|
|
--- a/Utilities/cmnghttp2/cmakeconfig.h.in
|
|
+++ b/Utilities/cmnghttp2/cmakeconfig.h.in
|
|
@@ -14,5 +14,15 @@
|
|
/* Define to 1 if you have the <arpa/inet.h> header file. */
|
|
#cmakedefine HAVE_ARPA_INET_H 1
|
|
|
|
/* Define to 1 if you have the <netinet/in.h> header file. */
|
|
#cmakedefine HAVE_NETINET_IN_H 1
|
|
+
|
|
+/* Define to 1 if you have the `clock_gettime` function. */
|
|
+#cmakedefine HAVE_CLOCK_GETTIME 1
|
|
+
|
|
+/* Define to 1 if you have the `GetTickCount64` function. */
|
|
+#cmakedefine HAVE_GETTICKCOUNT64 1
|
|
+
|
|
+/* Define to 1 if you have the <sysinfoapi.h> header file. */
|
|
+#cmakedefine HAVE_SYSINFOAPI_H 1
|
|
+
|
|
diff --git a/lib/includes/nghttp2/nghttp2.h b/lib/includes/nghttp2/nghttp2.h
|
|
index 65077dd5..fa22081c 100644
|
|
--- a/Utilities/cmnghttp2/lib/includes/nghttp2/nghttp2.h
|
|
+++ b/Utilities/cmnghttp2/lib/includes/nghttp2/nghttp2.h
|
|
@@ -2540,6 +2540,23 @@ NGHTTP2_EXTERN void
|
|
NGHTTP2_EXTERN void nghttp2_option_set_no_http_messaging(nghttp2_option *option,
|
|
int val);
|
|
|
|
+/**
|
|
+ * @function
|
|
+ *
|
|
+ * This function sets the rate limit for the incoming stream reset
|
|
+ * (RST_STREAM frame). It is server use only. It is a token-bucket
|
|
+ * based rate limiter. |burst| specifies the number of tokens that is
|
|
+ * initially available. The maximum number of tokens is capped to
|
|
+ * this value. |rate| specifies the number of tokens that are
|
|
+ * regenerated per second. An incoming RST_STREAM consumes one token.
|
|
+ * If there is no token available, GOAWAY is sent to tear down the
|
|
+ * connection. |burst| and |rate| default to 1000 and 33
|
|
+ * respectively.
|
|
+ */
|
|
+NGHTTP2_EXTERN void
|
|
+nghttp2_option_set_stream_reset_rate_limit(nghttp2_option *option,
|
|
+ uint64_t burst, uint64_t rate);
|
|
+
|
|
/**
|
|
* @function
|
|
*
|
|
diff --git a/lib/nghttp2_option.c b/lib/nghttp2_option.c
|
|
index ee0cd0f0..43d4e952 100644
|
|
--- a/Utilities/cmnghttp2/lib/nghttp2_option.c
|
|
+++ b/Utilities/cmnghttp2/lib/nghttp2_option.c
|
|
@@ -59,6 +59,14 @@ void nghttp2_option_set_no_rfc9113_leading_and_trailing_ws_validation(
|
|
option->no_http_messaging = val;
|
|
}
|
|
|
|
+
|
|
+void nghttp2_option_set_stream_reset_rate_limit(nghttp2_option *option,
|
|
+ uint64_t burst, uint64_t rate) {
|
|
+ option->opt_set_mask |= NGHTTP2_OPT_STREAM_RESET_RATE_LIMIT;
|
|
+ option->stream_reset_burst = burst;
|
|
+ option->stream_reset_rate = rate;
|
|
+}
|
|
+
|
|
void nghttp2_option_set_max_reserved_remote_streams(nghttp2_option *option,
|
|
uint32_t val) {
|
|
option->opt_set_mask |= NGHTTP2_OPT_MAX_RESERVED_REMOTE_STREAMS;
|
|
diff --git a/lib/nghttp2_option.h b/lib/nghttp2_option.h
|
|
index b228a075..2259e184 100644
|
|
--- a/Utilities/cmnghttp2/lib/nghttp2_option.h
|
|
+++ b/Utilities/cmnghttp2/lib/nghttp2_option.h
|
|
@@ -67,12 +67,18 @@ typedef enum {
|
|
NGHTTP2_OPT_MAX_DEFLATE_DYNAMIC_TABLE_SIZE = 1 << 9,
|
|
NGHTTP2_OPT_NO_CLOSED_STREAMS = 1 << 10,
|
|
NGHTTP2_OPT_MAX_OUTBOUND_ACK = 1 << 11,
|
|
+ NGHTTP2_OPT_STREAM_RESET_RATE_LIMIT = 1 << 15,
|
|
} nghttp2_option_flag;
|
|
|
|
/**
|
|
* Struct to store option values for nghttp2_session.
|
|
*/
|
|
struct nghttp2_option {
|
|
+ /**
|
|
+ * NGHTTP2_OPT_STREAM_RESET_RATE_LIMIT
|
|
+ */
|
|
+ uint64_t stream_reset_burst;
|
|
+ uint64_t stream_reset_rate;
|
|
/**
|
|
* NGHTTP2_OPT_MAX_SEND_HEADER_BLOCK_LENGTH
|
|
*/
|
|
diff --git a/lib/nghttp2_ratelim.c b/lib/nghttp2_ratelim.c
|
|
new file mode 100644
|
|
index 00000000..7011655b
|
|
--- /dev/null
|
|
+++ b/Utilities/cmnghttp2/lib/nghttp2_ratelim.c
|
|
@@ -0,0 +1,75 @@
|
|
+/*
|
|
+ * nghttp2 - HTTP/2 C Library
|
|
+ *
|
|
+ * Copyright (c) 2023 nghttp2 contributors
|
|
+ *
|
|
+ * Permission is hereby granted, free of charge, to any person obtaining
|
|
+ * a copy of this software and associated documentation files (the
|
|
+ * "Software"), to deal in the Software without restriction, including
|
|
+ * without limitation the rights to use, copy, modify, merge, publish,
|
|
+ * distribute, sublicense, and/or sell copies of the Software, and to
|
|
+ * permit persons to whom the Software is furnished to do so, subject to
|
|
+ * the following conditions:
|
|
+ *
|
|
+ * The above copyright notice and this permission notice shall be
|
|
+ * included in all copies or substantial portions of the Software.
|
|
+ *
|
|
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
|
|
+ * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
|
|
+ * MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
|
|
+ * NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE
|
|
+ * LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
|
|
+ * OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
|
|
+ * WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
|
|
+ */
|
|
+#include "nghttp2_ratelim.h"
|
|
+#include "nghttp2_helper.h"
|
|
+
|
|
+void nghttp2_ratelim_init(nghttp2_ratelim *rl, uint64_t burst, uint64_t rate) {
|
|
+ rl->val = rl->burst = burst;
|
|
+ rl->rate = rate;
|
|
+ rl->tstamp = 0;
|
|
+}
|
|
+
|
|
+void nghttp2_ratelim_update(nghttp2_ratelim *rl, uint64_t tstamp) {
|
|
+ uint64_t d, gain;
|
|
+
|
|
+ if (tstamp == rl->tstamp) {
|
|
+ return;
|
|
+ }
|
|
+
|
|
+ if (tstamp > rl->tstamp) {
|
|
+ d = tstamp - rl->tstamp;
|
|
+ } else {
|
|
+ d = 1;
|
|
+ }
|
|
+
|
|
+ rl->tstamp = tstamp;
|
|
+
|
|
+ if (UINT64_MAX / d < rl->rate) {
|
|
+ rl->val = rl->burst;
|
|
+
|
|
+ return;
|
|
+ }
|
|
+
|
|
+ gain = rl->rate * d;
|
|
+
|
|
+ if (UINT64_MAX - gain < rl->val) {
|
|
+ rl->val = rl->burst;
|
|
+
|
|
+ return;
|
|
+ }
|
|
+
|
|
+ rl->val += gain;
|
|
+ rl->val = nghttp2_min(rl->val, rl->burst);
|
|
+}
|
|
+
|
|
+int nghttp2_ratelim_drain(nghttp2_ratelim *rl, uint64_t n) {
|
|
+ if (rl->val < n) {
|
|
+ return -1;
|
|
+ }
|
|
+
|
|
+ rl->val -= n;
|
|
+
|
|
+ return 0;
|
|
+}
|
|
diff --git a/lib/nghttp2_ratelim.h b/lib/nghttp2_ratelim.h
|
|
new file mode 100644
|
|
index 00000000..866ed3f0
|
|
--- /dev/null
|
|
+++ b/Utilities/cmnghttp2/lib/nghttp2_ratelim.h
|
|
@@ -0,0 +1,57 @@
|
|
+/*
|
|
+ * nghttp2 - HTTP/2 C Library
|
|
+ *
|
|
+ * Copyright (c) 2023 nghttp2 contributors
|
|
+ *
|
|
+ * Permission is hereby granted, free of charge, to any person obtaining
|
|
+ * a copy of this software and associated documentation files (the
|
|
+ * "Software"), to deal in the Software without restriction, including
|
|
+ * without limitation the rights to use, copy, modify, merge, publish,
|
|
+ * distribute, sublicense, and/or sell copies of the Software, and to
|
|
+ * permit persons to whom the Software is furnished to do so, subject to
|
|
+ * the following conditions:
|
|
+ *
|
|
+ * The above copyright notice and this permission notice shall be
|
|
+ * included in all copies or substantial portions of the Software.
|
|
+ *
|
|
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
|
|
+ * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
|
|
+ * MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
|
|
+ * NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE
|
|
+ * LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
|
|
+ * OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
|
|
+ * WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
|
|
+ */
|
|
+#ifndef NGHTTP2_RATELIM_H
|
|
+#define NGHTTP2_RATELIM_H
|
|
+
|
|
+#ifdef HAVE_CONFIG_H
|
|
+# include <config.h>
|
|
+#endif /* HAVE_CONFIG_H */
|
|
+
|
|
+#include <nghttp2/nghttp2.h>
|
|
+
|
|
+typedef struct nghttp2_ratelim {
|
|
+ /* burst is the maximum value of val. */
|
|
+ uint64_t burst;
|
|
+ /* rate is the amount of value that is regenerated per 1 tstamp. */
|
|
+ uint64_t rate;
|
|
+ /* val is the amount of value available to drain. */
|
|
+ uint64_t val;
|
|
+ /* tstamp is the last timestamp in second resolution that is known
|
|
+ to this object. */
|
|
+ uint64_t tstamp;
|
|
+} nghttp2_ratelim;
|
|
+
|
|
+/* nghttp2_ratelim_init initializes |rl| with the given parameters. */
|
|
+void nghttp2_ratelim_init(nghttp2_ratelim *rl, uint64_t burst, uint64_t rate);
|
|
+
|
|
+/* nghttp2_ratelim_update updates rl->val with the current |tstamp|
|
|
+ given in second resolution. */
|
|
+void nghttp2_ratelim_update(nghttp2_ratelim *rl, uint64_t tstamp);
|
|
+
|
|
+/* nghttp2_ratelim_drain drains |n| from rl->val. It returns 0 if it
|
|
+ succeeds, or -1. */
|
|
+int nghttp2_ratelim_drain(nghttp2_ratelim *rl, uint64_t n);
|
|
+
|
|
+#endif /* NGHTTP2_RATELIM_H */
|
|
diff --git a/lib/nghttp2_session.c b/lib/nghttp2_session.c
|
|
index a45cbeef..ec5024d0 100644
|
|
--- a/Utilities/cmnghttp2/lib/nghttp2_session.c
|
|
+++ b/Utilities/cmnghttp2/lib/nghttp2_session.c
|
|
@@ -36,6 +36,7 @@
|
|
#include "nghttp2_option.h"
|
|
#include "nghttp2_http.h"
|
|
#include "nghttp2_pq.h"
|
|
+#include "nghttp2_time.h"
|
|
#include "nghttp2_debug.h"
|
|
|
|
/*
|
|
@@ -443,6 +444,10 @@ static int session_new(nghttp2_session **session_ptr,
|
|
NGHTTP2_DEFAULT_MAX_CONCURRENT_STREAMS;
|
|
(*session_ptr)->pending_enable_push = 1;
|
|
|
|
+ nghttp2_ratelim_init(&(*session_ptr)->stream_reset_ratelim,
|
|
+ NGHTTP2_DEFAULT_STREAM_RESET_BURST,
|
|
+ NGHTTP2_DEFAULT_STREAM_RESET_RATE);
|
|
+
|
|
if (server) {
|
|
(*session_ptr)->server = 1;
|
|
}
|
|
@@ -521,6 +526,12 @@ static int session_new(nghttp2_session **session_ptr,
|
|
if (option->opt_set_mask & NGHTTP2_OPT_MAX_OUTBOUND_ACK) {
|
|
(*session_ptr)->max_outbound_ack = option->max_outbound_ack;
|
|
}
|
|
+
|
|
+ if (option->opt_set_mask & NGHTTP2_OPT_STREAM_RESET_RATE_LIMIT) {
|
|
+ nghttp2_ratelim_init(&(*session_ptr)->stream_reset_ratelim,
|
|
+ option->stream_reset_burst,
|
|
+ option->stream_reset_rate);
|
|
+ }
|
|
}
|
|
|
|
rv = nghttp2_hd_deflate_init2(&(*session_ptr)->hd_deflater,
|
|
@@ -4143,6 +4154,23 @@ static int session_process_priority_frame(nghttp2_session *session) {
|
|
return nghttp2_session_on_priority_received(session, frame);
|
|
}
|
|
|
|
+static int session_update_stream_reset_ratelim(nghttp2_session *session) {
|
|
+ if (!session->server || (session->goaway_flags & NGHTTP2_GOAWAY_SUBMITTED)) {
|
|
+ return 0;
|
|
+ }
|
|
+
|
|
+ nghttp2_ratelim_update(&session->stream_reset_ratelim,
|
|
+ nghttp2_time_now_sec());
|
|
+
|
|
+ if (nghttp2_ratelim_drain(&session->stream_reset_ratelim, 1) == 0) {
|
|
+ return 0;
|
|
+ }
|
|
+
|
|
+ return nghttp2_session_add_goaway(session, session->last_recv_stream_id,
|
|
+ NGHTTP2_INTERNAL_ERROR, NULL, 0,
|
|
+ NGHTTP2_GOAWAY_AUX_NONE);
|
|
+}
|
|
+
|
|
int nghttp2_session_on_rst_stream_received(nghttp2_session *session,
|
|
nghttp2_frame *frame) {
|
|
int rv;
|
|
@@ -4172,7 +4200,8 @@ int nghttp2_session_on_rst_stream_received(nghttp2_session *session,
|
|
if (nghttp2_is_fatal(rv)) {
|
|
return rv;
|
|
}
|
|
- return 0;
|
|
+
|
|
+ return session_update_stream_reset_ratelim(session);
|
|
}
|
|
|
|
static int session_process_rst_stream_frame(nghttp2_session *session) {
|
|
@@ -6980,6 +70009,9 @@ int nghttp2_session_add_goaway(nghttp2_session *session, int32_t last_stream_id,
|
|
nghttp2_mem_free(mem, item);
|
|
return rv;
|
|
}
|
|
+
|
|
+ session->goaway_flags |= NGHTTP2_GOAWAY_SUBMITTED;
|
|
+
|
|
return 0;
|
|
}
|
|
|
|
diff --git a/lib/nghttp2_session.h b/lib/nghttp2_session.h
|
|
index 34d2d585..b119329a 100644
|
|
--- a/Utilities/cmnghttp2/lib/nghttp2_session.h
|
|
+++ b/Utilities/cmnghttp2/lib/nghttp2_session.h
|
|
@@ -39,6 +39,7 @@
|
|
#include "nghttp2_buf.h"
|
|
#include "nghttp2_callbacks.h"
|
|
#include "nghttp2_mem.h"
|
|
+#include "nghttp2_ratelim.h"
|
|
|
|
/* The global variable for tests where we want to disable strict
|
|
preface handling. */
|
|
@@ -102,6 +103,10 @@ typedef struct {
|
|
/* The default value of maximum number of concurrent streams. */
|
|
#define NGHTTP2_DEFAULT_MAX_CONCURRENT_STREAMS 0xffffffffu
|
|
|
|
+/* The default values for stream reset rate limiter. */
|
|
+#define NGHTTP2_DEFAULT_STREAM_RESET_BURST 1000
|
|
+#define NGHTTP2_DEFAULT_STREAM_RESET_RATE 33
|
|
+
|
|
/* Internal state when receiving incoming frame */
|
|
typedef enum {
|
|
/* Receiving frame header */
|
|
@@ -176,7 +181,9 @@ typedef enum {
|
|
/* Flag means GOAWAY was sent */
|
|
NGHTTP2_GOAWAY_SENT = 0x4,
|
|
/* Flag means GOAWAY was received */
|
|
- NGHTTP2_GOAWAY_RECV = 0x8
|
|
+ NGHTTP2_GOAWAY_RECV = 0x8,
|
|
+ /* Flag means GOAWAY has been submitted at least once */
|
|
+ NGHTTP2_GOAWAY_SUBMITTED = 0x10
|
|
} nghttp2_goaway_flag;
|
|
|
|
/* nghttp2_inflight_settings stores the SETTINGS entries which local
|
|
@@ -227,6 +234,9 @@ struct nghttp2_session {
|
|
/* Queue of In-flight SETTINGS values. SETTINGS bearing ACK is not
|
|
considered as in-flight. */
|
|
nghttp2_inflight_settings *inflight_settings_head;
|
|
+ /* Stream reset rate limiter. If receiving excessive amount of
|
|
+ stream resets, GOAWAY will be sent. */
|
|
+ nghttp2_ratelim stream_reset_ratelim;
|
|
/* The number of outgoing streams. This will be capped by
|
|
remote_settings.max_concurrent_streams. */
|
|
size_t num_outgoing_streams;
|
|
diff --git a/lib/nghttp2_time.c b/lib/nghttp2_time.c
|
|
new file mode 100644
|
|
index 00000000..2a5f1a6f
|
|
--- /dev/null
|
|
+++ b/Utilities/cmnghttp2/lib/nghttp2_time.c
|
|
@@ -0,0 +1,62 @@
|
|
+/*
|
|
+ * nghttp2 - HTTP/2 C Library
|
|
+ *
|
|
+ * Copyright (c) 2023 nghttp2 contributors
|
|
+ *
|
|
+ * Permission is hereby granted, free of charge, to any person obtaining
|
|
+ * a copy of this software and associated documentation files (the
|
|
+ * "Software"), to deal in the Software without restriction, including
|
|
+ * without limitation the rights to use, copy, modify, merge, publish,
|
|
+ * distribute, sublicense, and/or sell copies of the Software, and to
|
|
+ * permit persons to whom the Software is furnished to do so, subject to
|
|
+ * the following conditions:
|
|
+ *
|
|
+ * The above copyright notice and this permission notice shall be
|
|
+ * included in all copies or substantial portions of the Software.
|
|
+ *
|
|
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
|
|
+ * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
|
|
+ * MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
|
|
+ * NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE
|
|
+ * LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
|
|
+ * OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
|
|
+ * WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
|
|
+ */
|
|
+#include "nghttp2_time.h"
|
|
+
|
|
+#ifdef HAVE_TIME_H
|
|
+# include <time.h>
|
|
+#endif /* HAVE_TIME_H */
|
|
+
|
|
+#ifdef HAVE_SYSINFOAPI_H
|
|
+# include <sysinfoapi.h>
|
|
+#endif /* HAVE_SYSINFOAPI_H */
|
|
+
|
|
+#ifndef HAVE_GETTICKCOUNT64
|
|
+static uint64_t time_now_sec(void) {
|
|
+ time_t t = time(NULL);
|
|
+
|
|
+ if (t == -1) {
|
|
+ return 0;
|
|
+ }
|
|
+
|
|
+ return (uint64_t)t;
|
|
+}
|
|
+#endif /* HAVE_GETTICKCOUNT64 */
|
|
+
|
|
+#ifdef HAVE_CLOCK_GETTIME
|
|
+uint64_t nghttp2_time_now_sec(void) {
|
|
+ struct timespec tp;
|
|
+ int rv = clock_gettime(CLOCK_MONOTONIC, &tp);
|
|
+
|
|
+ if (rv == -1) {
|
|
+ return time_now_sec();
|
|
+ }
|
|
+
|
|
+ return (uint64_t)tp.tv_sec;
|
|
+}
|
|
+#elif defined(HAVE_GETTICKCOUNT64)
|
|
+uint64_t nghttp2_time_now_sec(void) { return GetTickCount64() / 1000; }
|
|
+#else /* !HAVE_CLOCK_GETTIME && !HAVE_GETTICKCOUNT64 */
|
|
+uint64_t nghttp2_time_now_sec(void) { return time_now_sec(); }
|
|
+#endif /* !HAVE_CLOCK_GETTIME && !HAVE_GETTICKCOUNT64 */
|
|
diff --git a/lib/nghttp2_time.h b/lib/nghttp2_time.h
|
|
new file mode 100644
|
|
index 00000000..03c0bbe9
|
|
--- /dev/null
|
|
+++ b/Utilities/cmnghttp2/lib/nghttp2_time.h
|
|
@@ -0,0 +1,38 @@
|
|
+/*
|
|
+ * nghttp2 - HTTP/2 C Library
|
|
+ *
|
|
+ * Copyright (c) 2023 nghttp2 contributors
|
|
+ *
|
|
+ * Permission is hereby granted, free of charge, to any person obtaining
|
|
+ * a copy of this software and associated documentation files (the
|
|
+ * "Software"), to deal in the Software without restriction, including
|
|
+ * without limitation the rights to use, copy, modify, merge, publish,
|
|
+ * distribute, sublicense, and/or sell copies of the Software, and to
|
|
+ * permit persons to whom the Software is furnished to do so, subject to
|
|
+ * the following conditions:
|
|
+ *
|
|
+ * The above copyright notice and this permission notice shall be
|
|
+ * included in all copies or substantial portions of the Software.
|
|
+ *
|
|
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
|
|
+ * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
|
|
+ * MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
|
|
+ * NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE
|
|
+ * LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
|
|
+ * OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
|
|
+ * WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
|
|
+ */
|
|
+#ifndef NGHTTP2_TIME_H
|
|
+#define NGHTTP2_TIME_H
|
|
+
|
|
+#ifdef HAVE_CONFIG_H
|
|
+# include <config.h>
|
|
+#endif /* HAVE_CONFIG_H */
|
|
+
|
|
+#include <nghttp2/nghttp2.h>
|
|
+
|
|
+/* nghttp2_time_now_sec returns seconds from implementation-specific
|
|
+ timepoint. If it is unable to get seconds, it returns 0. */
|
|
+uint64_t nghttp2_time_now_sec(void);
|
|
+
|
|
+#endif /* NGHTTP2_TIME_H */
|